Commodore 64 Breadbin #2 Referb : 326298 Part 1

I picked up another Commodore 64 breadbin model. It had a rough time in storage from the looks of it. The system has been in a damp dirty storage area, there were several of them being sold by the same person, in similar conditions along with some other old 80s era computers like Apple ii systems. I guess they were stored in a basement somewhere that had some real water/moisture problems.

As you can see from the outside it is a bit dirty, and some keys were missing. This was I think the second best looking of the batch. Below you can see the inside, the paper shield was a mess, black mildew along the bottom. A good bit of dirt inside. After seeing it in the bag, I decided I wasn’t even opening it inside. So I took it out back and opened it there. I removed the cardboard shield and it went strait to the trash can. The case we taken apart and hosed down to get the worst of the dirt off. I wiped the keyboard down a bit and the board before taking them in. The case parts went it the tub and got a really good scrubbing.

I removed the RF Shield and cleaned the board with some 91% IPA. It turns out to be a bit of an interesting board. Yes the screws are mostly rusty, the RF Shield and Cartridge port plate tells a tail of too much water too. On close inspection the board looks ok for the most part, the legs of some of the components are rusted, I clipped a them and the tips just fell off. This board has obviously been worked on in the past. The inner cardboard sheet that was above the bottom RF Shield went strait to the trash, it was about as awful as the upper cardboard shield.. I kind of like this brass looking shield, but without the cardboard to go with it, I won’t be reinstalling it. I don’t care enough to make a new cardboard piece.

You may notice the wires in the above picture. This is a 326298 Rev A board. An early board that only has the 5 Pin Video port. This board was built in 82 based on the unsocketed chips. The board had extensive work done to it. All of the main chips are socketed. They are all dated second half of 84. The 5 Pin Video port was replaced with a full 8 Pin Video port. There are two wires running off from that port, and various cut traces on the top and bottom to separate out the additional pins. I think in the VIC II area there were possibly some other changes. The VIC II area cage was (and still is) rather rusted as well as the RF modulator top plate, and the RF Rca port was all rusted.

So after the ipa bath I hooked up the board.

It worked, no issues. Next I tested the keyboard, it worked, minus the two broken keys. Some keys were not very responsive though. I did a full teardown of the keyboard to clean it properly.

I first removed all of the keycaps with my keycap puller. I recommend one, they are rather cheap and good insurance to prevent breaking the old plastic. I next desoldered the wires on the ShiftLock key. I had removed the tape from around the keyboard, as you can see, to get to the screws under it. After removing the screws the board lifts off, and you can see the plungers then.

I took out the plungers and put them to the side, then took the keyboard frame and sent it to the tub and some warm very soapy water. I also soaked the keys in the soapy water. Then scrubbed the keyboard and keycaps with a toothbrush and rinsed them well and dried them. I also took the springs which were dirty and some were rather rusty. I put the springs into some White Vinegar. The Vinegar removes the rust, it does make the metal a bit dull looking. I expect if you leave them in too long you may break down the metal too, so I kept checking on them. They cleaned up well, the worst of them you could tell were actually pitted but were still in working order. I then washed the vinegar off with some water and dried the spring as best I could. I placed all of that on a towel to dry properly.

While that was drying, I took some IPA on a qtip and lightly wiped the contacts on the circut board. We don’t want to remove the conductive coating. If you clean too much of it off they keys won’t work. Next I took the plungers, and wiped the shaft part with a damp cloth to get any dirt off, I didn’t wipe the contacts on the plungers, they looked pretty good. They were mostly clean overall due to being covered by the keycaps and in the keyboard frame holes.

All of the good plungers and two broken ones.

Well, I had watched Perifractic’s Lego 64 videos, and I got an idea to try on the broken plungers. They did still work, as I had tested the keyboard with them, they just won’t hold a key now.

So I found a Lego laying around. You see the full piece I started with there in the lower left. I cut it in half, cleaned the plunger up and fited it to it. I shaved it down to go into the plunger shaft a little for more surface area and strength. Then I glued it in with a combination of Bondic and Super Glue gel. I DID have to file down the Lego piece, it was too large and the Commodore Key cap wouldn’t go on it. I used my small Diamond Grit Needle Files from Harbor Freight (they are just small files, I got the Diamond Grit ones, they seemed to work well for me on plastics). I will say that the glue doesn’t hold well, these tops will come off. So it isn’t a great fix, but I think it will work. I am still waiting on replacement Plungers and springs for the keyboard. I put the one plunger back at the British Pound symbol location, but I put the other at another key that is less likely to see much use. The 8 key gets a lot of use.

Here is the keyboard frame after reassembly.

Here is the keyboard back together back in the cleaned upper case. I tested it and it all works. The * key doesn’t work very well though.. When I get the new plungers in, I will probably remove the circuit board again and check that key. I don’t know if it it is the plunger, or dirt, or the contacts on the circuit board. Other than that and the missing caps, the keyboard was quite responsive, better than my other C64. That one I did not remove the board to clean the contacts. Removing to swap the plunger and check that key isn’t too bad. I will only have to desolder the ShiftLock key and remove the screws. The plungers that I am not working with will all stay as long as the keycaps are still on the keys can’t come out.

I does look much better than it did, but it is very streaked. The Power LED plate was actually corroded to the point much of the paint was lifted and flaking off. Corroded Aluminium.. Ya, I guess a good bit of moisture for a long period of time. I plan to get a replacement Badge and maybe a matching Power LED plate, I just don’t know what I want to go with.

Next I started on some preventative maintenance as well as rust removal. I had already removed the rusty tops of the VIC II area and the Modulator top cover. I then desoldered the Cartridge Plate and the VIC II cage which is rather rusty. I did alot of cleanup on the RF Modulator cover and Cartridge plate. A combination of wire brushes, sanding, and polishing with the Dremel etc. To remove the stickers easily, I put a little WD40 on them and let it sit. When I was done they were pretty decent. I tried some Vinegar on the RF Modulator cover, but that removes the protective coating that was still on some areas of it, so I stopped that. I did soak all of the rusty screws (basically every screw in this thing) in the Vinegar to get the rust off. I also removed the Fuse holder pieces, and fuse, they were quite corroded. I placed them into the Vinegar as well (well not the fuse). The Vinegar did clean the corrosion pretty well off the Fuse holder, but it left those areas black, I then polished them back to a shiny surface before reinstalling them. When all the rust was off of the screws and Cartridge plate and RF Modulator cover, I put some “Teflon Non-Stick Dry-Film Lubricant” on them. Not to Lubricate them so much, but to put a protective film on them to help prevent them rusting again. I did the same with the keyboard springs after they were dry. I don’t use the stuff on plastics though it puts a white film on that is hard to remove. So I put it on before putting them in place.

I resoldered the Cartridge Plate back to the board. I also touched up some solder points on the board. The VIC II cage will not be going back in either. I think the VIC will stay cooler without it, and with a proper heatsink installed.

Here is the board reinstalled after cleaning up the rusty bits.

The board was tested again and still worked. So next I installed a few heatsinks.

The 5 Volt Regulator doesn’t have much of a heatsink on it. The Rivet is loose and the heatsink is spinning around. So I decided to remove it and fix that as best I could. I took the heatsink off of it. I placed it on a new 2 Amp capable 5 Volt Regulator, it wasn’t needed, but that is what I keep around. I was a concerned that with the age and heat that Regulator dealt with over the years plus that loose tiny heatsink that it really should be replaced before it fails. When these regulators fail they most often fail open, meaning they will push the full voltage through them instead of dropping it or cutting off the voltage completely.. That fries the ics in the board. I have not heard of them failing inside the C64, while they are the big issue inside the C64 power supplies. With that very tiny heatsink, which was also not making good thermal connection to the regulator I didn’t want to take a chance on it. This time I put a second folded back heatsink behind it with thermal compound between the heatsinks as well as on the back of the regulator and bolted it all together.

As far as the case repairs go, I guess I didn’t take any pictures to show that specifically. The top of the case is cracked in the front right corner, it appeared to have taken a hit to that corner. It also has 2 cracks in some of the screw supports. I used my solder iron on a lower temp to melt the inside of the crack in the corner of the case together again. Then I put some liquid Testors Model glue in from the back to smooth it out. That did start to melt the plastic, I removed the excess glue. I have found that if you use that stuff and it melts the plastic and there is too much excess glue the plastic won’t harden again. The one standoff in the top of the care there is cracked as well, I haven’t fixed that yet, I think maybe from the same trauma that cracked the top. Three of the standoffs that hold the keyboard in place were sheared off as well. Those I glue back on with superglue gel. I then clamped them for a day and left it sit. That will give me the best strength, they shouldn’t be stressed while it is curing, which is 24 hours to get to full strength per the manufactures directions that is. The clamping ensures they are down properly and the joint is thin and tight too. After that I put some Bondic glue around them, the Bondic won’t cure in the crack because it needs UV Light to cure. I have also found it doesn’t bond very well compared to Super Glue. It does retain some flexibility and have some hold, I find that can assist Super Glue because it holds so tight, but doesn’t flex and fractures.

This case is badly discolored and I don’t want to try to retrobright it. I picked up some Krylon Fusion All-In-One Paint+Primer “Matte River Rock” paint awhile back to potentially paint a 1541 case. The case had some small chips out of the bottom. I took some Tamiya Putty “white” and filled in and built up the missing areas. It is a potent thin putty that dries quickly, and sands well for me. I it seems to bond to the case plastic well (As the model glue fuses the plastic, so I would expect the model putty to grip it well too). When I was done with the physical repairs to the bottom portion of the case, I put a even coat of the Matte River Rock paint on it. It turned out well. After the paint dried I found a crack show in the center of the half circle of the video port in the middle of the case. I glued that with the Testors Liquid model glue, I hope it holds well. Later I will put on some epoxy to help give that crack a little more support (I should have used Epoxy on the keyboard plungers instead) . I think once the board is reinstalled it will have more support where that crack is as well.

I haven’t done anything to the top of the case so far except weld and glue the one crack. The one case clip on it is broken off and lost. There are also 2 screws posts in the top that are cracked. I have thought about getting one of Birt’s “Hey Birt!” case saver kits to get a new case clip, I could use one of the reinforcement pieces on the cracked stand off, and have spares for the future. As I have to fix that case clip, I don’t want to paint the case yet, I will likely scratch up the paint having it upside down for those repairs. I will put several coats on the case. I want to test the paint on something with a Matt Finish clear over it. Some paints don’t mix well, and can cause the lower paint to lift or got to a crackle like finish. I have found that even with paints from the same company.. So I will test the Krylon Matt Finish first on a scrap of similar plastic (probably a modern computer case bezel). I want to put the clear over it, even though I like the existing Matt Finish of the paint as it should help protect it better.

So for now that is about it for this C64. In the future I will be doing more to it. The remaining repairs to the case. That include the Clip and post repair as well as painting and installing a new Badge plate. Checking out the * key, as well as installing the replacement keys and springs. I also have a capacitor replacement kit for it. With the 84 Breadbin I already worked on, I had found some capacitors that showed evidence of failing, so I figure this one is going to be served well by replacing them. I do wonder if that, especially the ones in the RF Modulator, may make a difference in the video output. I may or may not install some additional heatsinks. The computer is working fine, but it does have bad jailbars, so I may do something with that too at some point. I don’t know of removing the modulator and building up a replacement would help that or not.

I would love to know where the other Breadbins that were sold with this ended up and see that they were properly cared for. There was a very interesting VIC that I would have loved to see, but I wasn’t paying that kind of cash for a VIC let alone one that looked like it spend a few years sitting in water.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s